Multiple vulnerabilities in Oracle Communications Cloud Native Core Network Function Cloud Native Environment



Published: 2022-01-27
Risk Medium
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2021-3448
CVE-2021-33560
CWE-ID CWE-345
CWE-203
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Oracle Communications Cloud Native Core Network Function Cloud Native Environment
Server applications / DLP, anti-spam, sniffers

Vendor Oracle

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Insufficient verification of data authenticity

EUVDB-ID: #VU52065

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-3448

CWE-ID: CWE-345 - Insufficient Verification of Data Authenticity

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a DNS Cache Poisoning attack.

The vulnerability exists due to dnsmasq relies only on transmission ID when processing DNS queries and uses the same port for outgoing requests, when configured to given network interface. A remote attacker can guess the random transmission ID to forge a reply and get it accepted by dnsmasq.As a result, an attacker can perform a DNS Cache Poisoning attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Function Cloud Native Environment: 1.9.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujan2022.html?936688

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Observable discrepancy

EUVDB-ID: #VU56684

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-33560

CWE-ID: CWE-203 - Observable discrepancy

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to observable discrepancy. A remote attacker can gain unauthorized access to sensitive information on the system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Function Cloud Native Environment: 1.9.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujan2022.html?936688

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###