Input validation error in indexzero nconf



Published: 2022-06-29
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-21803
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
nconf
Universal components / Libraries / Libraries used by multiple products

Vendor indexzero

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Input validation error

EUVDB-ID: #VU64696

Risk: Medium

CVSSv3.1: 6.4 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-21803

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to modify files on the system.

The vulnerability exists due to .set() function that is responsible for setting the configuration properties is vulnerable to Prototype Pollution. A remote attacker can provide a specially crafted property, leading to prototype object pollution.

Mitigation

Install update from vendor's website.

Vulnerable software versions

nconf: 0.1.0 - 0.11.3


CPE2.3 External links

http://snyk.io/vuln/SNYK-JS-NCONF-2395478
http://github.com/indexzero/nconf/releases/tag/v0.11.4
http://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2632450
http://github.com/indexzero/nconf/pull/397
http://bugzilla.redhat.com/show_bug.cgi?id=2074689

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###