Denial of service in jquery-validation



Published: 2022-07-04 | Updated: 2022-07-27
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-31147
CWE-ID CWE-185
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
jquery-validation
Web applications / JS libraries

Vendor jquery-validation

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Incorrect Regular Expression

EUVDB-ID: #VU64913

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-31147

CWE-ID: CWE-185 - Incorrect Regular Expression

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper input validation when processing untrusted input within a regular expression. A remote attacker can pass specially crafted data to the application and perform regular expression denial of service (ReDoS) attack.

Note, the vulnerability exists due to incomplete fix for #VU63477 (CVE-2021-43306).

Mitigation

Install updates from vendor's website.

Vulnerable software versions

jquery-validation: 1.6.0 - 1.19.4


CPE2.3 External links

http://github.com/jquery-validation/jquery-validation/releases/tag/1.19.5
http://github.com/jquery-validation/jquery-validation/commit/5bbd80d27fc6b607d2f7f106c89522051a9fb0dd
http://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-ffmh-x56j-9rc3

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###