Multiple vulnerabilities in Samba



Published: 2022-07-27
Risk Medium
Patch available YES
Number of vulnerabilities 5
CVE-ID CVE-2022-32746
CVE-2022-32745
CVE-2022-32744
CVE-2022-32742
CVE-2022-2031
CWE-ID CWE-416
CWE-835
CWE-264
CWE-401
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Samba
Server applications / Directory software, identity management

Vendor Samba

Security Bulletin

This security bulletin contains information about 5 vulnerabilities.

1) Use-after-free

EUVDB-ID: #VU65827

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-32746

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due to a use-after-free error when handling LDAP requests. A remote user with ability to edit privileged properties, such as userAccountControl, can send a specially crafted LDAP request to the server, trigger a use-after-free error and perform a denial of service (DoS) attack.


Mitigation

Install updates from vendor's website.

Vulnerable software versions

Samba: 4.16.0 - 4.16.3, 4.15.0 - 4.15.8, 4.14.0 - 4.14.13, 4.13.0 - 4.13.17, 4.12.0 - 4.12.15, 4.11.0 - 4.11.17, 4.10.0 - 4.10.18, 4.9.0 - 4.9.18, 1.9.16 - 1.9.18, 4.8.0 - 4.8.12, 4.7.0 - 4.7.12, 4.6.0 - 4.6.16, 4.5.0 - 4.5.16, 4.4.0 - 4.4.16, 4.3.0 - 4.3.13, 4.2.0 - 4.2.14, 4.1.0 - 4.1.23, 4.0.0 - 4.0.26, 3.6.0 - 3.6.25, 3.5 - 3.5.22, 3.1 - 3.1.0, 3.4 - 3.4.17, 2.2 - 2.2a, 3.3 - 3.3.16, 3.0 - 3.0.37, 3.2 - 3.2.15, 2.18.3, 2.0 - 2.0.10


CPE2.3 External links

http://www.samba.org/samba/security/CVE-2022-32746.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Infinite loop

EUVDB-ID: #VU65826

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-32745

CWE-ID: CWE-835 - Loop with Unreachable Exit Condition ('Infinite Loop')

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due to infinite loop when processing LDAP requests. A remote user can send a specially crafted LDAP request to the server, consume all available system resources and cause denial of service conditions.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Samba: 4.16.0 - 4.16.3, 4.15.2 - 4.15.8, 4.14.10 - 4.14.13, 4.13.14 - 4.13.17


CPE2.3 External links

http://www.samba.org/samba/security/CVE-2022-32745.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) Permissions, Privileges, and Access Controls

EUVDB-ID: #VU65825

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-32744

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote user to force password change requests.

The vulnerability exists due to tickets received by the kpasswd service were decrypted without specifying that only that service's own keys should be tried. A remote user can force the server to accept tickets encrypted with any key and initiate password change requests for any Samba AD user.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Samba: 4.16.0 - 4.16.3, 4.15.0 - 4.15.8, 4.14.0 - 4.14.13, 4.13.0 - 4.13.17, 4.12.0 - 4.12.15, 4.11.0 - 4.11.17, 4.10.0 - 4.10.18, 4.9.0 - 4.9.18, 4.8.0 - 4.8.12, 4.7.0 - 4.7.12, 4.6.0 - 4.6.16, 4.5.0 - 4.5.16, 4.4.0 - 4.4.16, 4.3.0 - 4.3.13


CPE2.3 External links

http://www.samba.org/samba/security/CVE-2022-32744.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) Memory leak

EUVDB-ID: #VU65824

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-32742

CWE-ID: CWE-401 - Improper Release of Memory Before Removing Last Reference ('Memory Leak')

Exploit availability: No

Description

The vulnerability allows a remote user to gain access to sensitive information.

The vulnerability exists due memory leak when handling SMB1 requests. A remote user with ability to write data to a file share can force the application to leak memory and gain access to potentially sensitive information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Samba: 4.16.0 - 4.16.3, 4.15.0 - 4.15.8, 4.14.0 - 4.14.13, 4.13.0 - 4.13.17, 4.12.0 - 4.12.15, 4.11.0 - 4.11.17, 4.10.0 - 4.10.18, 4.9.0 - 4.9.18, 1.9.16 - 1.9.18, 4.8.0 - 4.8.12, 4.7.0 - 4.7.12, 4.6.0 - 4.6.16, 4.5.0 - 4.5.16, 4.4.0 - 4.4.16, 4.3.0 - 4.3.13, 4.2.0 - 4.2.14, 4.1.0 - 4.1.23, 4.0.0 - 4.0.26, 3.6.0 - 3.6.25, 3.5 - 3.5.22, 3.1 - 3.1.0, 3.4 - 3.4.17, 2.2 - 2.2a, 3.3 - 3.3.16, 3.0 - 3.0.37, 3.2 - 3.2.15, 2.18.3, 2.0 - 2.0.10


CPE2.3 External links

http://www.samba.org/samba/security/CVE-2022-32742.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

5) Security restrictions bypass

EUVDB-ID: #VU65820

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-2031

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote user to escalate privileges on the system.

The vulnerability exists due to the way the KDC kpasswd service handles password change requests. A remote user can escalate privileges on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Samba: 4.16.0 - 4.16.3, 4.15.0 - 4.15.8, 4.14.0 - 4.14.13, 4.13.0 - 4.13.17, 4.12.0 - 4.12.15, 4.11.0 - 4.11.17, 4.10.0 - 4.10.18, 4.9.0 - 4.9.18, 4.8.0 - 4.8.12, 4.7.0 - 4.7.12, 4.6.0 - 4.6.16, 4.5.0 - 4.5.16, 4.4.0 - 4.4.16, 4.3.0 - 4.3.13, 4.2.0 - 4.2.14, 4.1.0 - 4.1.23, 4.0.0 - 4.0.26, 1.9.16 - 1.9.18, 3.6.0 - 3.6.25, 3.5 - 3.5.22, 3.1 - 3.1.0, 3.4 - 3.4.17, 2.2 - 2.2a, 3.3 - 3.3.16, 3.0 - 3.0.37, 3.2 - 3.2.15, 2.18.3, 2.0 - 2.0.10


CPE2.3 External links

http://www.samba.org/samba/security/CVE-2022-2031.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###