SUSE update for the Linux Kernel



Published: 2023-03-17
Risk Medium
Patch available YES
Number of vulnerabilities 21
CVE-ID CVE-2022-3606
CVE-2022-36280
CVE-2022-38096
CVE-2022-47929
CVE-2023-0045
CVE-2023-0179
CVE-2023-0266
CVE-2023-0590
CVE-2023-0597
CVE-2023-1076
CVE-2023-1095
CVE-2023-1118
CVE-2023-1195
CVE-2023-22995
CVE-2023-22998
CVE-2023-23000
CVE-2023-23004
CVE-2023-23006
CVE-2023-23559
CVE-2023-25012
CVE-2023-26545
CWE-ID CWE-476
CWE-787
CWE-254
CWE-190
CWE-416
CWE-401
CWE-843
CWE-20
CWE-466
CWE-415
Exploitation vector Local
Public exploit Public exploit code for vulnerability #5 is available.
Vulnerable software
Subscribe
SUSE Real Time Module
Operating systems & Components / Operating system

SUSE Linux Enterprise Micro for Rancher
Operating systems & Components / Operating system

SUSE Linux Enterprise Real Time 15
Operating systems & Components / Operating system

SUSE Linux Enterprise Micro
Operating systems & Components / Operating system

kernel-rt_debug
Operating systems & Components / Operating system package or component

kernel-rt
Operating systems & Components / Operating system package or component

kernel-source-rt
Operating systems & Components / Operating system package or component

kernel-devel-rt
Operating systems & Components / Operating system package or component

dlm-kmp-rt
Operating systems & Components / Operating system package or component

cluster-md-kmp-rt
Operating systems & Components / Operating system package or component

gfs2-kmp-rt-debuginfo
Operating systems & Components / Operating system package or component

kernel-rt_debug-devel-debuginfo
Operating systems & Components / Operating system package or component

ocfs2-kmp-rt-debuginfo
Operating systems & Components / Operating system package or component

kernel-rt_debug-devel
Operating systems & Components / Operating system package or component

kernel-rt_debug-debuginfo
Operating systems & Components / Operating system package or component

kernel-rt-debuginfo
Operating systems & Components / Operating system package or component

dlm-kmp-rt-debuginfo
Operating systems & Components / Operating system package or component

kernel-rt_debug-debugsource
Operating systems & Components / Operating system package or component

kernel-rt-debugsource
Operating systems & Components / Operating system package or component

gfs2-kmp-rt
Operating systems & Components / Operating system package or component

cluster-md-kmp-rt-debuginfo
Operating systems & Components / Operating system package or component

kernel-syms-rt
Operating systems & Components / Operating system package or component

kernel-rt-devel
Operating systems & Components / Operating system package or component

kernel-rt-devel-debuginfo
Operating systems & Components / Operating system package or component

ocfs2-kmp-rt
Operating systems & Components / Operating system package or component

Vendor SuSE

Security Bulletin

This security bulletin contains information about 21 vulnerabilities.

1) NULL pointer dereference

EUVDB-ID: #VU73782

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-3606

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error within the find_prog_by_sec_insn() function in tools/lib/bpf/libbpf.c of the BPF component. A local user can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Out-of-bounds write

EUVDB-ID: #VU71480

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-36280

CWE-ID: CWE-787 - Out-of-bounds write

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error within the vmw_kms_cursor_snoo() function in drivers/gpu/vmxgfx/vmxgfx_kms.c in vmwgfx VMWare driver. A local user can trigger an out-of-bounds write and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) NULL pointer dereference

EUVDB-ID: #VU73764

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-38096

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in vmwgfx driver in drivers/gpu/vmxgfx/vmxgfx_execbuf.c in GPU component of Linux kernel with device file '/dev/dri/renderD128 (or Dxxx)'. A local user can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) NULL pointer dereference

EUVDB-ID: #VU71479

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-47929

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in the traffic control subsystem in Linux kernel. A local user can pass pass a specially crafted traffic control configuration that is set up with "tc qdisc" and "tc class" commands and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Security features bypass

EUVDB-ID: #VU72469

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-0045

CWE-ID: CWE-254 - Security Features

Exploit availability: Yes

Description

The vulnerability allows a local user to bypass implemented security restrictions.

The vulnerability exists due to Linux kernel does not correctly mitigate SMT attacks. A local user can bypass Spectre-BTI user space mitigations and gain access to sensitive information.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Integer overflow

EUVDB-ID: #VU71173

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-0179

CWE-ID: CWE-190 - Integer overflow

Exploit availability: No

Description

The vulnerability allows a local  user to escalate privileges on the system.

The vulnerability exists due to an integer overflow within the nft_payload_copy_vlan() function in Linux kernel Netfilter. A local user can trigger an integer overflow and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Use-after-free

EUVDB-ID: #VU71482

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-0266

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a use-after-free error within the snd_ctl_elem_read() function. A local user can trigger a use-after-free error and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Use-after-free

EUVDB-ID: #VU72098

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-0590

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a use-after-free error within the qdisc_graft() function in net/sched/sch_api.c. A local user can trigger a use-after-free error and crash the kernel.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

9) Memory leak

EUVDB-ID: #VU73765

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-0597

CWE-ID: CWE-401 - Improper Release of Memory Before Removing Last Reference ('Memory Leak')

Exploit availability: No

Description

The vulnerability allows a local user to gain access to sensitive information.

The vulnerability exists due to memory leak within the Linux kernel cpu_entry_area mapping of X86 CPU data. A local user can gain access to sensitive information.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

10) Type Confusion

EUVDB-ID: #VU72742

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-1076

CWE-ID: CWE-843 - Access of Resource Using Incompatible Type ('Type Confusion')

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a type confusion error during initialization of TUN/TAP sockets. A local user can trigger a type confusion error and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

11) NULL pointer dereference

EUVDB-ID: #VU73783

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-1095

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in the nf_tables_updtable() function within the netfilter subsystem. A local user can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

12) Use-after-free

EUVDB-ID: #VU72734

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-1118

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the Linux kernel integrated infrared receiver/transceiver driver "drivers/media/rc/ene_ir.c" when detaching rc device. A local user can trigger a use-after-free error and execute arbitrary code with elevated privileges.


Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

13) Use-after-free

EUVDB-ID: #VU73784

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-1195

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a use-after-free error within the reconn_set_ipaddr_from_hostname() function in fs/cifs/connect.c in Linux kernel. A local user can perform a denial of service (DoS) attack.


Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

14) Input validation error

EUVDB-ID: #VU73767

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-22995

CWE-ID: CWE-20 - Improper input validation

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to insufficient validation of user-supplied input within the dwc3_qcom_acpi_register_core() function in drivers/usb/dwc3/dwc3-qcom.c. A local user can execute arbitrary code on the system with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

15) Return of pointer value outside of expected range

EUVDB-ID: #VU73768

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-22998

CWE-ID: CWE-466 - Return of pointer value outside of expected range

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to unexpected value of the pointer returned as value in the drm_gem_shmem_get_sg_table() function in drivers/gpu/drm/virtio/virtgpu_object.c. A local user can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

16) NULL pointer dereference

EUVDB-ID: #VU73769

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-23000

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error within the tegra_xusb_find_port_node() function in drivers/phy/tegra/xusb.c. A local user can pass specially crafted data to the system and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

17) NULL pointer dereference

EUVDB-ID: #VU73773

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-23004

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error within the get_sg_table() function in drivers/gpu/drm/arm/malidp_planes.c. A local user can pass specially crafted data to the system and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

18) NULL pointer dereference

EUVDB-ID: #VU73770

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-23006

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error within the mlx5_get_uars_page() function in drivers/net/ethernet/mellanox/mlx5/core/steering/dr_domain.c. A local user can pass specially crafted data to the systen and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

19) Integer overflow

EUVDB-ID: #VU72468

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-23559

CWE-ID: CWE-190 - Integer overflow

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to integer overflow within the rndis_query_oid() function in drivers/net/wireless/rndis_wlan.c. A local user can trigger an integer overflow and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

20) Use-after-free

EUVDB-ID: #VU71764

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-25012

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows an attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a use-after-free error within the bigben_remove() function in drivers/hid/hid-bigbenff.c. An attacker with physical access to the system can attach a specially crafted USB device to the system and cause a denial of service condition.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

21) Double Free

EUVDB-ID: #VU73766

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-26545

CWE-ID: CWE-415 - Double Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a double free in net/mpls/af_mpls.c during the renaming of a device. A local user can trigger a double free error and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Real Time Module: 15-SP3

SUSE Linux Enterprise Micro for Rancher: 5.2

SUSE Linux Enterprise Real Time 15: SP3

SUSE Linux Enterprise Micro: 5.1 - 5.2

kernel-rt_debug: before 5.3.18-150300.121.1

kernel-rt: before 5.3.18-150300.121.1

kernel-source-rt: before 5.3.18-150300.121.1

kernel-devel-rt: before 5.3.18-150300.121.1

dlm-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt: before 5.3.18-150300.121.1

gfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-devel: before 5.3.18-150300.121.1

kernel-rt_debug-debuginfo: before 5.3.18-150300.121.1

kernel-rt-debuginfo: before 5.3.18-150300.121.1

dlm-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-rt_debug-debugsource: before 5.3.18-150300.121.1

kernel-rt-debugsource: before 5.3.18-150300.121.1

gfs2-kmp-rt: before 5.3.18-150300.121.1

cluster-md-kmp-rt-debuginfo: before 5.3.18-150300.121.1

kernel-syms-rt: before 5.3.18-150300.121.1

kernel-rt-devel: before 5.3.18-150300.121.1

kernel-rt-devel-debuginfo: before 5.3.18-150300.121.1

ocfs2-kmp-rt: before 5.3.18-150300.121.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2023/suse-su-20230779-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###