Denial of service in giflib



Published: 2023-09-18 | Updated: 2024-03-07
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2023-39742
CWE-ID CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
GIFLIB
Client/Desktop applications / Multimedia software

Vendor GIFLIB Project

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Buffer overflow

EUVDB-ID: #VU80867

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2023-39742

CWE-ID: CWE-119 - Memory corruption

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error in getarg.c. A remote attacker can pass a specially crafted input to the application, trigger memory corruption and perform a denial of service (DoS) attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

GIFLIB: 5.2.0 - 5.2.1

External links

http://gist.github.com/huanglei3/ec9090096aa92445cf0a8baa8e929084
http://sourceforge.net/p/giflib/bugs/166/


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###