#VU14542 Security restrictions bypass


Published: 2018-08-28

Vulnerability identifier: #VU14542

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-1128

CWE-ID: CWE-264

Exploitation vector: Local network

Exploit availability: No

Vulnerable software:
Ceph
Server applications / Other server solutions

Vendor: Red Hat Inc.

Description

The vulnerability allows an adjacent attacker to conduct replay attack on the target system.

The vulnerability exists in ceph branches master, mimic, luminous and jewel due to cephx authentication protocol did not verify ceph clients correctly. An adjacent attacker with access to ceph cluster network who is able to sniff packets on network can authenticate with ceph service, perform actions allowed by ceph service, conduct replay attack and bypass security restrictions.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Ceph: All versions


CPE

External links
http://access.redhat.com/security/cve/cve-2018-1128


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability