#VU197 Resource exhaustion


Published: 2016-07-22 | Updated: 2019-04-15

Vulnerability identifier: #VU197

Vulnerability risk: Medium

CVSSv3.1: 5.9 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2016-3092

CWE-ID: CWE-400

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Commons FileUpload
Server applications / Frameworks for developing and running applications

Vendor: Apache Foundation

Description
The vulnerability allows a remote attacker to cause denial of service conditions on the target system.

The vulnerability exists due to input validation error when processing very long boundary strings within the MultipartStream class in Apache Commons Fileupload. A remote user can cause denial of service conditions by sending specially crafted boundary string and consume excessive CPU resources.

Successful exploitation of this vulnerability may result in denial of service attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache Commons FileUpload: 1.0 - 1.3.1


CPE

External links
http://svn.apache.org/viewvc?view=revision&revision=1743480


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability