#VU54698 Type confusion in Adobe Acrobat and Adobe Reader


Published: 2021-07-13 | Updated: 2021-10-13

Vulnerability identifier: #VU54698

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2021-35986

CWE-ID: CWE-843

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Adobe Acrobat
Client/Desktop applications / Office applications
Adobe Reader
Client/Desktop applications / Office applications

Vendor: Adobe

Description

The vulnerability allows a remote attacker to compromise the affected system

The vulnerability exists due to a boundary condition within the getAnnots method when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF document, trigger a type confusion error and execute arbitrary code on the system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 20.001.30020 - 20.013.20074, 2017.008.30051 - 2017.011.30197

Adobe Reader: 2020.001.30020 - 2020.013.20074, 2017.011.30156 - 2017.011.30197


CPE

External links
http://helpx.adobe.com/security/products/acrobat/apsb21-51.html
http://www.zerodayinitiative.com/advisories/ZDI-21-1145/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability