#VU64011 Input validation error


Published: 2022-06-07

Vulnerability identifier: #VU64011

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-25031

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Swagger UI
Web applications / Other software

Vendor: SmartBear

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to insufficient validation of user-supplied input. A remote attacker can trick the victim into opening a specially crafted URL to display remote OpenAPI definitions.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Swagger UI: 4.1.0 - 4.1.2


CPE

External links
http://github.com/swagger-api/swagger-ui/issues/4872
http://github.com/swagger-api/swagger-ui/releases/tag/v4.1.3
http://security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885
http://security.netapp.com/advisory/ntap-20220407-0004/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability