Remote code execution in PHP

Published: 2016-06-15 00:00:00 | Updated: 2017-03-20 15:27:30
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2016-5773
CVSSv3 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-416
Exploitation vector Network
Public exploit Not available
Vulnerable software PHP
Vulnerable software versions PHP 5.6.0
PHP 5.6.1
PHP 5.6.2
Show more
Vendor URL PHP Group

Security Advisory

1) Use-after-free error

Description

The vulnerability allows a remote attacker to execute arbitrary PHP code on the target system.

The vulnerability exists due to use-after-free in GC algorithm and unserialize. A remote attacker can create a specially crafted zval object and exploit the PHP process by taking over the EIP/RIP.

Successful exploitation of this vulnerability results in complete control over the vulnerable web application and execute arbitrary PHP code on the target system.

Remediation

Update to version 5.6.23.

External links

https://bugs.php.net/bug.php?id=72434

Back to List