#VU21135 Information disclosure


Published: 2020-04-07 | Updated: 2020-05-26

Vulnerability identifier: #VU21135

Vulnerability risk: Medium

CVSSv3.1: 4.8 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P/RL:O/RC:C]

CVE-ID: CVE-2019-14540

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: Yes

Vulnerable software:
jackson-databind
Universal components / Libraries / Libraries used by multiple products

Vendor: FasterXML

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to a polymorphic typing issue in the "com.zaxxer.hikari.HikariConfig". A remote attacker can gain unauthorized access to sensitive information on the system.

Mitigation
Install update from vendor's website.

Vulnerable software versions

jackson-databind: 2.0.0 - 2.9.9.2


CPE

External links
http://github.com/FasterXML/jackson-databind/blob/master/release-notes/VERSION-2.x
http://github.com/FasterXML/jackson-databind/issues/2410
http://github.com/FasterXML/jackson-databind/issues/2449


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.


Latest bulletins with this vulnerability