#VU57732 Input validation error in macOS


Published: 2021-10-27 | Updated: 2022-02-16

Vulnerability identifier: #VU57732

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-30903

CWE-ID: CWE-20

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
macOS
Operating systems & Components / Operating system

Vendor: Apple Inc.

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to insufficient validation of user-supplied input in Continuity Camera component. A local user can pass specially crafted input to the application and escalate privileges on the system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

macOS: 12.0 21A344


CPE

External links
http://support.apple.com/en-us/HT212869


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability