SUSE update for apache2



Published: 2021-06-22
Risk Medium
Patch available YES
Number of vulnerabilities 6
CVE-ID CVE-2020-13950
CVE-2020-35452
CVE-2021-26690
CVE-2021-26691
CVE-2021-30641
CVE-2021-31618
CWE-ID CWE-476
CWE-121
CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
SUSE Linux Enterprise Module for Packagehub Subpackages
Operating systems & Components / Operating system package or component

apache2-utils-debuginfo
Operating systems & Components / Operating system package or component

apache2-utils
Operating systems & Components / Operating system package or component

apache2-prefork-debuginfo
Operating systems & Components / Operating system package or component

apache2-prefork
Operating systems & Components / Operating system package or component

apache2
Operating systems & Components / Operating system package or component

apache2-event-debuginfo
Operating systems & Components / Operating system package or component

apache2-event
Operating systems & Components / Operating system package or component

apache2-doc
Operating systems & Components / Operating system package or component

apache2-worker-debuginfo
Operating systems & Components / Operating system package or component

apache2-worker
Operating systems & Components / Operating system package or component

apache2-devel
Operating systems & Components / Operating system package or component

apache2-debugsource
Operating systems & Components / Operating system package or component

apache2-debuginfo
Operating systems & Components / Operating system package or component

SUSE Linux Enterprise Module for Server Applications
Operating systems & Components / Operating system

SUSE Linux Enterprise Module for Basesystem
Operating systems & Components / Operating system

Vendor SuSE

Security Bulletin

This security bulletin contains information about 6 vulnerabilities.

1) NULL pointer dereference

EUVDB-ID: #VU53778

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-13950

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in mod_proxy_http. A remote attacker can pass specially crafted data to the application and perform a denial of service (DoS) attack.

Mitigation

Update the affected package apache2 to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Module for Packagehub Subpackages: 15-SP3

SUSE Linux Enterprise Module for Server Applications: 15-SP2 - 15-SP3

SUSE Linux Enterprise Module for Basesystem: 15-SP2 - 15-SP3

apache2-utils-debuginfo: before 2.4.43-3.22.1

apache2-utils: before 2.4.43-3.22.1

apache2-prefork-debuginfo: before 2.4.43-3.22.1

apache2-prefork: before 2.4.43-3.22.1

apache2: before 2.4.43-3.22.1

apache2-event-debuginfo: before 2.4.43-3.22.1

apache2-event: before 2.4.43-3.22.1

apache2-doc: before 2.4.43-3.22.1

apache2-worker-debuginfo: before 2.4.43-3.22.1

apache2-worker: before 2.4.43-3.22.1

apache2-devel: before 2.4.43-3.22.1

apache2-debugsource: before 2.4.43-3.22.1

apache2-debuginfo: before 2.4.43-3.22.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2021/suse-su-20212127-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Stack-based buffer overflow

EUVDB-ID: #VU53775

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-35452

CWE-ID: CWE-121 - Stack-based buffer overflow

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error when processing Digest nounces in mod_auth_digest. A remote unauthenticated attacker can send a specially crafted HTTP request, trigger stack overflow by one nul byte and crash the server.

Mitigation

Update the affected package apache2 to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Module for Packagehub Subpackages: 15-SP3

SUSE Linux Enterprise Module for Server Applications: 15-SP2 - 15-SP3

SUSE Linux Enterprise Module for Basesystem: 15-SP2 - 15-SP3

apache2-utils-debuginfo: before 2.4.43-3.22.1

apache2-utils: before 2.4.43-3.22.1

apache2-prefork-debuginfo: before 2.4.43-3.22.1

apache2-prefork: before 2.4.43-3.22.1

apache2: before 2.4.43-3.22.1

apache2-event-debuginfo: before 2.4.43-3.22.1

apache2-event: before 2.4.43-3.22.1

apache2-doc: before 2.4.43-3.22.1

apache2-worker-debuginfo: before 2.4.43-3.22.1

apache2-worker: before 2.4.43-3.22.1

apache2-devel: before 2.4.43-3.22.1

apache2-debugsource: before 2.4.43-3.22.1

apache2-debuginfo: before 2.4.43-3.22.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2021/suse-su-20212127-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) NULL pointer dereference

EUVDB-ID: #VU53777

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-26690

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in mod_session. A remote attacker can pass specially crafted data to the application and perform a denial of service (DoS) attack.

Mitigation

Update the affected package apache2 to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Module for Packagehub Subpackages: 15-SP3

SUSE Linux Enterprise Module for Server Applications: 15-SP2 - 15-SP3

SUSE Linux Enterprise Module for Basesystem: 15-SP2 - 15-SP3

apache2-utils-debuginfo: before 2.4.43-3.22.1

apache2-utils: before 2.4.43-3.22.1

apache2-prefork-debuginfo: before 2.4.43-3.22.1

apache2-prefork: before 2.4.43-3.22.1

apache2: before 2.4.43-3.22.1

apache2-event-debuginfo: before 2.4.43-3.22.1

apache2-event: before 2.4.43-3.22.1

apache2-doc: before 2.4.43-3.22.1

apache2-worker-debuginfo: before 2.4.43-3.22.1

apache2-worker: before 2.4.43-3.22.1

apache2-devel: before 2.4.43-3.22.1

apache2-debugsource: before 2.4.43-3.22.1

apache2-debuginfo: before 2.4.43-3.22.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2021/suse-su-20212127-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) NULL pointer dereference

EUVDB-ID: #VU53776

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-26691

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in mod_session. A a malicious backend server or SessionHeader can trigger a denial of service (DoS) condition.

Mitigation

Update the affected package apache2 to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Module for Packagehub Subpackages: 15-SP3

SUSE Linux Enterprise Module for Server Applications: 15-SP2 - 15-SP3

SUSE Linux Enterprise Module for Basesystem: 15-SP2 - 15-SP3

apache2-utils-debuginfo: before 2.4.43-3.22.1

apache2-utils: before 2.4.43-3.22.1

apache2-prefork-debuginfo: before 2.4.43-3.22.1

apache2-prefork: before 2.4.43-3.22.1

apache2: before 2.4.43-3.22.1

apache2-event-debuginfo: before 2.4.43-3.22.1

apache2-event: before 2.4.43-3.22.1

apache2-doc: before 2.4.43-3.22.1

apache2-worker-debuginfo: before 2.4.43-3.22.1

apache2-worker: before 2.4.43-3.22.1

apache2-devel: before 2.4.43-3.22.1

apache2-debugsource: before 2.4.43-3.22.1

apache2-debuginfo: before 2.4.43-3.22.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2021/suse-su-20212127-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Input validation error

EUVDB-ID: #VU53774

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-30641

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to incorrect parsing of Apache configuration files. An unexpected section could be matched with 'MergeSlashes OFF' option, leading to a potential security issue.

Mitigation

Update the affected package apache2 to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Module for Packagehub Subpackages: 15-SP3

SUSE Linux Enterprise Module for Server Applications: 15-SP2 - 15-SP3

SUSE Linux Enterprise Module for Basesystem: 15-SP2 - 15-SP3

apache2-utils-debuginfo: before 2.4.43-3.22.1

apache2-utils: before 2.4.43-3.22.1

apache2-prefork-debuginfo: before 2.4.43-3.22.1

apache2-prefork: before 2.4.43-3.22.1

apache2: before 2.4.43-3.22.1

apache2-event-debuginfo: before 2.4.43-3.22.1

apache2-event: before 2.4.43-3.22.1

apache2-doc: before 2.4.43-3.22.1

apache2-worker-debuginfo: before 2.4.43-3.22.1

apache2-worker: before 2.4.43-3.22.1

apache2-devel: before 2.4.43-3.22.1

apache2-debugsource: before 2.4.43-3.22.1

apache2-debuginfo: before 2.4.43-3.22.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2021/suse-su-20212127-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) NULL pointer dereference

EUVDB-ID: #VU53773

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-31618

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in mod_http2 in Apache HTTP server. A remote attacker can send specially crafted request to the server and perform a denial of service (DoS) attack.

Mitigation

Update the affected package apache2 to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Module for Packagehub Subpackages: 15-SP3

SUSE Linux Enterprise Module for Server Applications: 15-SP2 - 15-SP3

SUSE Linux Enterprise Module for Basesystem: 15-SP2 - 15-SP3

apache2-utils-debuginfo: before 2.4.43-3.22.1

apache2-utils: before 2.4.43-3.22.1

apache2-prefork-debuginfo: before 2.4.43-3.22.1

apache2-prefork: before 2.4.43-3.22.1

apache2: before 2.4.43-3.22.1

apache2-event-debuginfo: before 2.4.43-3.22.1

apache2-event: before 2.4.43-3.22.1

apache2-doc: before 2.4.43-3.22.1

apache2-worker-debuginfo: before 2.4.43-3.22.1

apache2-worker: before 2.4.43-3.22.1

apache2-devel: before 2.4.43-3.22.1

apache2-debugsource: before 2.4.43-3.22.1

apache2-debuginfo: before 2.4.43-3.22.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2021/suse-su-20212127-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###