Known vulnerabilities in plugins for browsers, activex components