#VU11628 Improper input validation


Published: 2018-04-09 | Updated: 2018-04-10

Vulnerability identifier: #VU11628

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-1000077

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
RubyGems
Universal components / Libraries / Libraries used by multiple products

Vendor: Ruby

Description

The vulnerability allows a remote unauthenticated attacker to write arbitrary files on the target system.

The weakness exists due to improper URL validation of the specification homepage attribute. A remote attacker can trick the victim into installing a malicious RubyGems gem and set an invalid homepage URL.

Mitigation
Update to version 2.7.6.

Vulnerable software versions

RubyGems: 2.2.0 - 2.7.5


CPE

External links
http://blog.rubygems.org/2018/02/15/2.7.6-released.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability